Email Not Sending

Incident Report for GPS Insight

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 23:34 CDT

Investigating

We sincerely apologize for the inconvenience — we are currently experiencing an issue that is preventing emails from being sent through ServiceBridge. This affects Work Order, Estimate, Invoice, and Payment Receipt emails. Our team is actively investigating and working to resolve this as quickly as possible. We truly appreciate your patience and understanding.
Posted Jun 09, 2026 - 20:09 CDT
This incident affected: Cloud Portal and Customer Portal.